This instance of Jira is read-only for non-SonarSourcers. Want to discuss a ticket or ask for help? Visit us at https://community.sonarsource.com/

Issues

Go to advanced search
Select view

Select search mode

Bug
Define compatibility with Plugin API instead of SonarQube
Unassigned
Łukasz Jarocki
Major
Fixed
Jul 19, 2022
Jul 22, 2022
Task
Upgrade github-action_release to v4
Unassigned
Philippe Perrin
Major
Fixed
Feb 23, 2022
Mar 3, 2022
Task
Remove dependency packaging feature for SonarLint compatible plugins
Unassigned
Julien Henry
Major
Fixed
Jan 14, 2021
Jan 5, 2022
New Feature
Add plugin property 'nodeJsMinVersion'
Unassigned
Julien Henry
Major
Fixed
Sep 8, 2020
Oct 4, 2021
Jun 3, 2020
New Feature
Add plugin property 'jreMinVersion'
Unassigned
Julien Henry
Major
Fixed
May 19, 2020
Jun 8, 2020
Jun 3, 2020
New Feature
Add support of display version field when generating plugin manifest
Unassigned
Jean-Baptiste Lièvremont
Major
Fixed
Jan 11, 2017
Feb 10, 2017
Feb 2, 2017
New Feature
Add a metadata to flag plugins compatible with SonarLint
Unassigned
Julien Henry
Major
Fixed
Jun 13, 2016
Jun 23, 2016
Jun 20, 2016
Improvement
Ability to override the minimal supported version of SonarQube
Unassigned
Simon Brandhof
Major
Fixed
Mar 10, 2016
Mar 15, 2016
Improvement
Change groupId from org.codehaus.sonar to org.sonarsource.sonar-packaging-maven-plugin
Unassigned
Simon Brandhof
Major
Fixed
Oct 9, 2015
Oct 9, 2015
Oct 16, 2015
Improvement
sonar-packaging-m-p should support new groupId of sonar-plugin-api
Unassigned
Simon Brandhof
Major
Fixed
Sep 27, 2015
Oct 9, 2015
Improvement
The dependencies with scope 'system' are not packaged in plugin libs
Unassigned
Freddy Mallet
Major
Won't Fix
Apr 9, 2013
Jan 14, 2021
1-11 of 11